Back to overview
Downtime
Outage at US
Jun 28 at 11:38am CST
Affected services
Network
Resolved
Jun 28 at 04:24pm CST
After taking measures to restart, the issue was resolved.
Affected services
Network
Created
Jun 28 at 11:38am CST
We encountered a router issue in the US and are investigating it further.
Affected services
Network