Back to overview
Downtime

Unexpected router downtime.

Feb 23, 2024 at 2:04pm UTC
Affected services
WHMCS
Network

Resolved
Feb 23, 2024 at 2:13pm UTC

It's up and service is recover now.

Created
Feb 23, 2024 at 2:04pm UTC

The router has encountered an unexpected failure, and we are currently working to resolve it.